Aller au contenu
  • Information

    Bonjour et bienvenue à tous !

    Avant de vous inscrire, nous vous invitons à lire avec une attention particulière les règles régissant l'utilisation de cette plateforme communautaire.

    En vous inscrivant sur le forum AudiPassion, vous certifiez avoir lu et accepté notre charte d'utilisation.

    Afin d'avoir vos droits d'accès validés et de pouvoir participer à la communauté avec vos publications, dès lors que vous aurez pris connaissance de cette dernière et que vous aurez procédé à votre inscription, vous devez "OBLIGATOIREMENT" vous présenter dans la sous-section ici: Présentation - Votre Garage de la section principale "AUDIPASSION".

    Merci à tous les nouveaux inscrits de ne pas présenter dans le détail vos anciennes voitures, ses voitures actuelles ou vos problèmes, il y a d'autres sections pour ça suivant le modèle de votre auto, mais en contrepartie il vous sera demandé de faire un effort sur votre présentation pour qu'elle ne se fasse pas en 2 lignes seulement !

    En d'autres termes, si nous avons le sentiment que votre présentation est bâclée ou ne correspond pas aux règles de cette section, elle ne sera pas approuvée et votre inscription ne vous permettra toujours pas de pouvoir contribuer ailleurs que dans cette section de présentation.

    Nous vous souhaitons à tous une excellente visite sur le forum.

    iDevX

    N'oubliez pas de nous rejoindre sur Facebook fb_icon_20x20.png


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

[Tuto] Online Services (Audi Connect, Google Earth & Trafic Online) en WIFI


Allez-vous utiliser ou avez-vous utilisé ce tuto?  

125 membres ont voté

  1. 1. Allez-vous utiliser ou avez-vous utilisé ce tuto?



Messages recommandés

Bonjour à tous,

 

Nous sommes heureux frankiegom et moi-même de partager avec vous cette méthode qui permet de bénéficier des fonctionnalités online du MMI en WiFi, sans passer par l'interface AMI.

 

Vous trouverez ICI la procédure qu'il faudra parfois adapter si vous choisissez d'autres équipements que ceux documentés.

 

Le script d'installation se trouve ICI.Comme à l’accoutumée, vous devez le dézipper et copier les fichiers à la racine de la carte SD.

 

Pour ceux qui s'inquiètent, également ICI, le script de désinstallation.

Si toutefois vous rencontrez des difficultés, voici un script pour aider au diagnostic ICI. Envoyez moi le contenu du répertoire créé sur la carte SD (date et heure de l'exécution).

****New****20/08/2015 Le diag et affichage de la configuration directement sur le MMI ICI (diag 2.01)

 

Pour l'instant, pas de possibilité de fonctionner avec le partage de connexion de votre smartphone, c'est en cours d'étude.

 

Enjoy.

Lien vers le commentaire
Partager sur d’autres sites

Oui, car le routeur n'a qu'une interface wifi qui lui sert à se connecter au MMI.

 

 

Envoyé de mon iPhone en utilisant Tapatalk

Lien vers le commentaire
Partager sur d’autres sites

Mais il devrait y avoir moyen de connecter un smartphone directement, par le port USB, sauf qu'on ne l'a pas testé, ni documenté.

Je pense que le FW du routeur le supporte, mais chaque téléphone est différent, alors à voir...

 

Il faut bien comprendre que la raison d'être de ce montage, c'est de libérer le port AMI pour autre chose (un iPod 80G dans mon cas). Ça permet aussi de limiter la filasse dans la boite à gant/accoudoir.

Lien vers le commentaire
Partager sur d’autres sites

Mince ...

La solution via le smartphone Galaxy S4 me fait trop envie

 

Mais bon en attendant cela se fera avec une clef 3G

Lien vers le commentaire
Partager sur d’autres sites

Je me permets de rajouter une petite question...

 

Pour ceux qui comme moi ont déjà fait les manips pour avoir GE via l'AMI (+ TP link + smartphone ou clef 3G) et qui veulent passer à cette solution (wifi + tp link + clef 3g)

 

Faut il annuler toute la configuration préconisée par le super tutoriel de Thierry 13 dans le menu vert + script ?

Et si oui => Comment ?

Lien vers le commentaire
Partager sur d’autres sites

non les 2 sont compatibles. Tu changes de solution comme tu veux sans re-modifier la configuration.


Envoyé de mon iPhone en utilisant Tapatalk

Lien vers le commentaire
Partager sur d’autres sites

Normalement le menu vert c'est kif kif, tu repasses juste dedans pour vérifier que tout est bon!

 

Ensuite tu fais une sauvegarde de la configuration de ton TP-Link avant de la modifier au cas ou.

 

Enfin, une fois que ça marche, tu branches ton S4, tu le mets en partage USB, et tu nous dis ce qui se passe. On verra à partir de là ce qu'il y a à faire.

 

Et oui, comme le dit hsd92, on peut aussi remettre le câble sur l'ami.

 

C'est magique ! ;)

Lien vers le commentaire
Partager sur d’autres sites

Merci a vous.

 

Pour le moment je n'ai pas declé3G donc je vais rester sur la solution direct sur l'AMI. Bon en meme temps, l'AMI je m'en fou un peu mais après tout cela pourrait servir.

Lien vers le commentaire
Partager sur d’autres sites

Bonjour à tous,

 

Tout d'abord, un grand bravo à HSD92 et Frankiegom. C'est vraiment un super boulot !

 

Dans le tuto (très bien fait au demeurant), je rajouterais à la fin du chapitre 3 "redémarrer le MMI". En effet, après avoir activé le WLAN, les réglages Wi-Fi n'apparaissaient pas sur ma voiture (une A5 Sportback FL) jusqu'à ce que je le reboot.

 

Sinon, je viens d'essayer de l'installer, et ça ne fonctionne pas, pour le moment (mais je ne suis pas inquiet):

 

Pour info, j'étais connecté auparavant avec l'autre méthode, sur la prise AMI.

 

En me connectant avec le laptop sur le Wi-Fi de la voiture, je récupére une adresse IP par le DHCP du routeur MR3020 et la connexion à Internet se passe bien... mais pas le MMI qui m'affiche "SIM" en bas de l'écran et qui me dit que Google Earth est "offline". J'ai essayé de redémarrer 15 fois le MMI, mais rien à faire. Le laptop, lui, se connecte bien à Internet pourtant en passant par le MMI.

 

Les logs enregistrés par le script affichent "success" sur les 22 étapes.

 

J'ai essayé "uninstall fair mode" dans le green menu, mais rien. Dans la config IP du MMI, l'IP semble fixée sur 192.168.1.1 et la gateway ("UG") est 192.168.1.254, ce qui me semble correct.

 

Qu'est-ce-que je loupe ???

 

Pour finir (j'ai quand même passé 2 heures dans ma voiture), j'ai essayé de réexécuter le script, mais le MMI indique dans les logs qu'il est déjà installé. Dois-je exécuter le script de désinstallation avant de réexécuter l'autre ? Le MMI devrait-il être en DHCP ou IP fixe ? Qu'est-ce-que j'ai fait pour que le logo "SIM" s'affiche en bas de l'écran ?

 

Merci d'avance !

 

Fred

Lien vers le commentaire
Partager sur d’autres sites

J'oubliais: je peux également pinger le MMI (192.168.1.1) depuis mon laptop. Je pense donc qu'au niveau réseau, tout fonctionne, mais que le MMI essaie de sortir sur Internet via une autre interface que le Wi-Fi.

Lien vers le commentaire
Partager sur d’autres sites

J'oubliais: je peux également pinger le MMI (192.168.1.1) depuis mon laptop. Je pense donc qu'au niveau réseau, tout fonctionne, mais que le MMI essaie de sortir sur Internet via une autre interface que le Wi-Fi.

 

Question par acquis de conscience: tu n'as pas le slot SIM entre les deux slots SD card en façade du MMI par hasard?

Lien vers le commentaire
Partager sur d’autres sites

J'oubliais: je peux également pinger le MMI (192.168.1.1) depuis mon laptop. Je pense donc qu'au niveau réseau, tout fonctionne, mais que le MMI essaie de sortir sur Internet via une autre interface que le Wi-Fi.

 

En général c'est le GW va en 192.168.1.1

Lien vers le commentaire
Partager sur d’autres sites

Oui, mais là 192.168.1.1 c'est le MMI et on veut qu'il passe par le routeur. Et comme la règle veut qu'à défaut de la première adresse du réseau, on utilise la dernière pour la passerelle, c'est 192.168.1.254 qui a été choisi (mais ça aurait pu être à peu près n'importe quelle autre adresse hors du pool dhcp du MMI)!

 

;)

Lien vers le commentaire
Partager sur d’autres sites

 

Question par acquis de conscience: tu n'as pas le slot SIM entre les deux slots SD card en façade du MMI par hasard?

 

Non, pas de slot SIM... J'aurais préféré, cela m'aurait évité les manips avec l'AMI, le Wifi, et le remplissage de boîte à gants !

 

Lorsque j'étais connecté via la prise AMI, le logo "SIM" ne s'affichait pas, j'avais les mêmes indications sur l'écran que ceux du tuto (TP, logo Bluetooth, etc.).

Lien vers le commentaire
Partager sur d’autres sites

Je n'ai pas le logo SIM non plus. Tout ce que je peux te conseiller pour l'instant c'est de revérifier tous les écrans du menu vert. Peut-être as-tu activé/désactivé une option qui provoque cet effet de bord?

Lien vers le commentaire
Partager sur d’autres sites

s-fredo, as tu vérifié que les DNS était bon? Dans la partie resolv.conf, tu dois avoir "nameserver 8.8.8.8 nameserveur 8.8.4.4" (depuis le green menu/config/config ip) Si tu as vu que la default gateway était bien 192.168.1.254, c'est que le MMI récupère les informations du DHCP du MR3020.

Il ne faut pas faire l'uninstall du fair mode, donc il faut le réactiver. Et dernier point, pour réinstaller le script, il faut passer la désinstallation avant. C'est pour s'assurer de conserver les fichiers d'origines sur le MMI sans avoir 15 versions... C'est ce qui permet de revenir en arrière.

Lien vers le commentaire
Partager sur d’autres sites

Bonjour,

 

voici mon retour d expérience.

 

J ai essayé la manip avec un raspberry avec 2 dongle wifi. (1 pour se connecter au MMI et l autre pour se connecter sur le hotspot du tel android) en utilisant le openwrt pour le rpi.

 

J ai vérifier si la config fonctionne (ping) via mon pc connecter en lan vers le rpi, pas de soucis.

J ai également essayé en mettant le tel en modem usb, ça fonctionne. (ping).

 

mais lorsqu on interroge depuis le mmi la rien (sauf une fois mais extrêmement lent et je suis partis en timeout).

 

Du coup j ai un peu investiguer, et je m aperçois que le mmi ne prend plus d apresse ip (dhcp ou ip fixe : celle du tuto 192.168.1.254).

la y a déjà un couac dans la config (script d install ?) ou j ai loupé qq chose ?

 

qq question :

a quoi sert t mmelauncher.cfg et mme-becker.sh ?

serait-il possible d avoir les sources Ontika ?

 

faut encore que je teste en me connectant sur le mmi en root, juste pour essayer de changer les routes

 

demain on me prete un rpi 2 egalement

 

+

Lien vers le commentaire
Partager sur d’autres sites

Bonjour,

 

Le principe est peu conventionnel. Le MMI est en IP fixe (192.168.1.1) et offre une AP wifi sur laquelle tu connectes ton routeur en IP fixe aussi (192.168.1.254). Ce routeur fait office de serveur DHCP. Le MMI lance un pseudo démon, le mme-bescker.sh qui lance un client DHCP pour obtenir la passerelle (il passe par des fichiers intermédiaires).

Quant à la grosse lenteur sur le MMI, je l'ai observé dans une configuration batarde (genre le nws.conf manquant). Regarde le fichier de log sur la carte SD. Le cas échéant, la désinstall remet tel que c'était.

 

Pour te connecter en root sur le MMI, tu peux utiliser le script suivant https://dl.orangedox.com/MQh6UU5TwvVVarikka/MMI-3GP-change-root-pssword.zip

Si tu ne change pas le mot de passe, c'est 123456.

Lien vers le commentaire
Partager sur d’autres sites

@leponot

 

Peux-tu préciser un peu tes observations? L'adresse IP du MMI est fixe, c'est 192.168.1.1, il ne la récupère pas du routeur. Le routeur sert principalement à fournir une route par défaut et une IP secondaire pour l'accès à Google Earth.

 

Tu donnes l'impression d'avoir fait tout tes tests du rPi, mais as tu essayer de pinger le MMI, le routeur, 8.8.8.8, google.com, de ton PC connecté au hotspot MMI?

 

Serait-il possible d'avoir des copies d'écran des différents écrans de config du menu vert, en particulier ceux qui ont trait à la configuration réseau (adresses, routes, DNS...), les trois écrans "Show..." donc?

Lien vers le commentaire
Partager sur d’autres sites

le principe avec les tp link c est bon, y a juste la passerelle au niveau du mmi.

 

si je passe le script d install, le mmi n est plus capable d affecter une ip en dhcp ex :

avant le script, si je me connecte au mmi en wifi, j obtenais une ip entre 192.168.1.100 et 192.168.1.110, après le passage du script c est impossible.

 

les test je les ai fait depuis le rpi et depuis mon pc connecter au rpi par lan.

 

bonne idée, je vais essayer en me connectant au mmi avec le pc

 

les copies je les faits demain mais elles sont identiques a votre config il me semble

 

vous tiens au courant

 

Possible d avoir l image Ontika ?

 

thks

Lien vers le commentaire
Partager sur d’autres sites

C'est normal. Le script désactive le serveur DHCP du MMI afin qu'il n'y en ait qu'un sur le réseau, celui du routeur. N'as-tu pas configuré le serveur DHCP sur ton RPI, sur l'interface qui se connecte au MMI?

 

PS: Je t'ai envoyé le script en MP.

Lien vers le commentaire
Partager sur d’autres sites

C'est normal. Le script désactive le serveur DHCP du MMI afin qu'il n'y en ait qu'un sur le réseau, celui du routeur. N'as-tu pas configuré le serveur DHCP sur ton RPI, sur l'interface qui se connecte au MMI?

 

PS: Je t'ai envoyé le script en MP.

 

oui thks je regarde ça demain la c est tard :)

 

nop pas fait, pas vu le bout également qui configure la gateway vers 192.168.1.254

Lien vers le commentaire
Partager sur d’autres sites

J'oubliais: je peux également pinger le MMI (192.168.1.1) depuis mon laptop. Je pense donc qu'au niveau réseau, tout fonctionne, mais que le MMI essaie de sortir sur Internet via une autre interface que le Wi-Fi.

 

Copies d'écran (ou photos) du menu vert, please?

- config/Show Network Configuration

- config/Show IP settings

- config/Show adapter settings

Lien vers le commentaire
Partager sur d’autres sites

 

oui thks je regarde ça demain la c est tard :)

 

nop pas fait, pas vu le bout également qui configure la gateway vers 192.168.1.254

 

Au fait, as-tu suivi le tuto à la lettre ou essayes-tu de l'émuler à partir d'une config/HW pré-existante? J'ai l'impression qu'au delà des étapes zappées (conf DHCP rPi & default gateway) que tu n'utilises pas non plus le même firmware sur le rPi (dispo sur ofmodemsandmen) ce qui t'aiderait à répliquer la configuration testée...

Lien vers le commentaire
Partager sur d’autres sites

 

Au fait, as-tu suivi le tuto à la lettre ou essayes-tu de l'émuler à partir d'une config/HW pré-existante? J'ai l'impression qu'au delà des étapes zappées (conf DHCP rPi & default gateway) que tu n'utilises pas non plus le même firmware sur le rPi (dispo sur ofmodemsandmen) ce qui t'aiderait à répliquer la configuration testée...

 

qu'est-ce qui te fait dire ça ? :P

 

http://www.ofmodemsandmen.com/download/MultiWeb310/RaspberryPi-310-MW2015-04-18.zip

 

j'ai même essayer la version debian, même combat

Lien vers le commentaire
Partager sur d’autres sites

 

qu'est-ce qui te fait dire ça ? :P

 

http://www.ofmodemsandmen.com/download/MultiWeb310/RaspberryPi-310-MW2015-04-18.zip

 

j'ai même essayer la version debian, même combat

 

Rien de particulier, mais le tuto étant écrit spécifiquement pour le MR3020, sans précision de ta part tout est possible. Et même si il n'y a pas de problème à faire une configuration similaire à partir de toute version suffisamment récente d'openWrt, ça ne fait pas de mal de savoir de quoi on parle précisément, surtout dès qu'il s'agit d'investiguer à distance sur du matos qu'on ne peut pas "toucher".

 

Mais tant que tu n'as pas configuré le DHCP sur le rPi ce n'est pas la peine de se prendre plus la tête, ça ne peut pas marcher.

Les copies d'écrans que j'ai demandées à s-fredo plus tôt pourront aussi aider à comprendre ce qui se pasee...

 

merci

Lien vers le commentaire
Partager sur d’autres sites

 

Copies d'écran (ou photos) du menu vert, please?

- config/Show Network Configuration

- config/Show IP settings

- config/Show adapter settings

 

Merci pour les retours.

 

Donc à la fraîche ce matin, j'ai donc dans l'ordre et en testant à chaque fois:

 

réinstallé le fair mode --> restart du MMI --> appliqué le script de désinstallation --> restart du MMI --> appliqué le script d'installation --> restart du MMI

 

Et ça ne fonctionne pas. Ce qu'il y a de neuf: le logo SIM ne s'affiche plus, et le MMI ne me demande plus d'insérer une SIM ou ne me dit plus que Google Earth est offline. Mais si j'essaie de me connecter à la page Infos de Audi Connect (météo, etc.), il affiche "patientez" pendant 30 secondes puis "la page ne peut être affichée pour le moment".

 

Je mettrai les copies écran ce soir. Pas eu le temps d'en faire ce matin.

 

Fred

Lien vers le commentaire
Partager sur d’autres sites

ok, l'affichage du logo sim et tes messages venaient de la desinstall du fair mode.

Je finis un script pour faire un diag.

 

 

Envoyé de mon iPhone en utilisant Tapatalk

Lien vers le commentaire
Partager sur d’autres sites

 

Merci pour les retours.

 

Donc à la fraîche ce matin, j'ai donc dans l'ordre et en testant à chaque fois:

 

réinstallé le fair mode --> restart du MMI --> appliqué le script de désinstallation --> restart du MMI --> appliqué le script d'installation --> restart du MMI

 

Et ça ne fonctionne pas. Ce qu'il y a de neuf: le logo SIM ne s'affiche plus, et le MMI ne me demande plus d'insérer une SIM ou ne me dit plus que Google Earth est offline. Mais si j'essaie de me connecter à la page Infos de Audi Connect (météo, etc.), il affiche "patientez" pendant 30 secondes puis "la page ne peut être affichée pour le moment".

 

Je mettrai les copies écran ce soir. Pas eu le temps d'en faire ce matin.

 

Fred

 

Vérifie déjà dans le menu vert que tu as bien une route par défaut vers 192.168.1.254 et que le nameserver pointe bien sur 8.8.8.8 et 8.8.4.4. Sans ça, le MMI ne pourra jamais se connecter.

 

Je suppose que le laptop a toujours accès par l’intermédiaire du hotspot MMI...

 

As-tu bien revalidé toute la config du routeur? Des copies des écrans modifiés seront les bienvenues le cas échéant.

Lien vers le commentaire
Partager sur d’autres sites

A vu de nez le rpi n'est pas connecté au MMI. c'est sans doute pour ça que la GW n'est pas passée!

 

tu ne dois pas pouvoir pinger entre les deux. Du rPi comme du MMI.

 

Revois l'association du rPi au hotspot MMI, vérifie que les deux machines se voient, et si la GW n'est toujours pas là, redémarre avant d'essayer.

 

F.

Lien vers le commentaire
Partager sur d’autres sites

Ça ne veut pas dire qu'il est connecté. Le client WiFi doit être associé au SSID du MMI, avec la passphrase que tu as configuré!

 

Revois le tutoriel et vérifie tous les écrans. En particulier celui qui parle de scanner le Wi-Fi...

 

Désolé, je suis sur la route avec juste mon tél sous la main...

Lien vers le commentaire
Partager sur d’autres sites

c’était en réponse a ça....

 

 

J'ai le sentiment, que tu n'as pas implémenté la partie serveur DHCP sur l'interface wifi qui se connecte au MMI.

 

Ça ne veut pas dire qu'il est connecté. Le client WiFi doit être associé au SSID du MMI, avec la passphrase que tu as configuré!

Revois le tutoriel et vérifie tous les écrans. En particulier celui qui parle de scanner le Wi-Fi...

Désolé, je suis sur la route avec juste mon tél sous la main...

 

 

j ai pas eu le temps de faire bcp de manip pour tester. je vais essayer depuis mon laptop une config similaire.

mais la 192.168.1.254 n apparaît jamais sur le MMI quelque soit le client qui se connecte dessus.

 

je vous tiens au courant car comme certain, j'ai n est pas envie de prendre une 2eme carte SIM, ça coûte assez chère ici.

comme ça le Rpi je le fou ds le coffre après :)

Modifié par leponot
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...