Aller au contenu
  • Information

    Bonjour et bienvenue à tous !

    Avant de vous inscrire, nous vous invitons à lire avec une attention particulière les règles régissant l'utilisation de cette plateforme communautaire.

    En vous inscrivant sur le forum AudiPassion, vous certifiez avoir lu et accepté notre charte d'utilisation.

    Afin d'avoir vos droits d'accès validés et de pouvoir participer à la communauté avec vos publications, dès lors que vous aurez pris connaissance de cette dernière et que vous aurez procédé à votre inscription, vous devez "OBLIGATOIREMENT" vous présenter dans la sous-section ici: Présentation - Votre Garage de la section principale "AUDIPASSION".

    Merci à tous les nouveaux inscrits de ne pas présenter dans le détail vos anciennes voitures, ses voitures actuelles ou vos problèmes, il y a d'autres sections pour ça suivant le modèle de votre auto, mais en contrepartie il vous sera demandé de faire un effort sur votre présentation pour qu'elle ne se fasse pas en 2 lignes seulement !

    En d'autres termes, si nous avons le sentiment que votre présentation est bâclée ou ne correspond pas aux règles de cette section, elle ne sera pas approuvée et votre inscription ne vous permettra toujours pas de pouvoir contribuer ailleurs que dans cette section de présentation.

    Nous vous souhaitons à tous une excellente visite sur le forum.

    iDevX

    N'oubliez pas de nous rejoindre sur Facebook fb_icon_20x20.png


  • En ligne récemment   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.

[Tuto] Retrait du défaut permanent 03175 "Invalid Data Set" suite à mise à jour MMI


Messages recommandés

Bonjour à tous,

 

Voici un petit tuto qui devrait rendre service à quelques uns d'entre vous, je l'espère.

 

En effet, suite à la mise à jour du firmware du MMI, nous obtenons 2x défauts permanent. C'est à dire qui ne s'effacent pas avec VCDS.

- Le premier: 03276 "Please Check Software Version Management " a déjà une solution. http://www.audienthu...n_SVMError.html

- le second: 03175 "Invalid Data Set" n'avait, à ma connaissance, pas de solution jusqu'à présent.

 

Voici donc comment je procède pour le retirer.

Cette procédure est la solution universelle/"simple" qui doit passer dans la majorité des cas. Pour les cas plus réfractaires, il existe une seconde solution plus poussée qui nécessite un cable pro et une procédure adaptée.

 

Je prend l'exemple du MMI 3G advanced que j'ai sous la main, mais la procédure est également valable (testée) pour:

- MMI 3GP (4H)

- MMI 3GP Hybrid (8F1)

- A3 MMI HIGH (8V)

- A4 MMI 3G (B8)

- A4 MMI 3G Standard

- A4 MMI 3GP

- Q7 MMI 3GP

 

Alors suite à la mise à jour, voici ce que nous obtenons:

Pour mon cas, suite au passage vers le firmware DF, ma réf du MMI 3G passe de D à M.

Et une fois les défauts effacés, il reste le fameux défaut 03175

 

fault1.png

 

- Commencer donc par activer le menu caché développeur si ce n'est pas déjà fait.

module 5F avec VCDS,

Adaptation (10)

Canal 06

Passer la valeur de 0 à 1 ....

 

 

 

- redémarrer le MMI (cf procédure de votre MMI), Pour le 3G advanced c'est ici:

audi_mmi.png

 

- ensuite il faut se rendre dans ce menu caché: appuis simultanné sur les boutons car et setup pendant 5s pour le MMI 3G Advanced

- Aller dans le sous menu: car > carmenuoperation

carmenu.jpg

- Attention1: pour chaque ligne, rajouter +1 à la valeur actuelle. Il est recommandé de prendre des photos des écrans avant de procéder pour éviter toute mauvaise manip.

- Attention2: n'oubliez pas de faire défiler la liste qui est plus grande que l'écran !

- quitter le menu caché avec le bouton "return"

- redémarrer le MMI (cf procédure)

- vous pouvez maintenant vérifier avec VCDS: le code défaut est effacé ! :race:

- se rendre à nouveau dans le menu caché

- rétablir les valeurs d'origine en soustrayant -1 à chaque ligne.

 

Enjoy !

 

fault2.png

 

=> résultat: un diag clean et qui ne montre pas que le mmi a été mis à jour hors concession.

 

 

 

Pour ceux qui veulent aller plus loin et comprendre la manip effectuée:

 

La mise à jour du firmware a apporté des nouvelles fonctionnalités et réglages qui n'existaient pas avant dans la version précédente.

Une zone mémoire qui était vierge a été remplie.

Fréquemment, il est d'usage que des clefs de contrôle (CRC, Checksums) soient calculées pour certaines zones mémoire afin de garantir l'intégrité du système et interdire/prévenir toute modification extérieure.

 

Pour je ne sais quelle raison, ces clefs ne sont pas calculées lors de la maj. Ce qui provoque le défaut.

 

Le fait de modifier TOUS les réglages a pour conséquence de provoquer le re-calcul de ces clefs.

Une fois fait, le défaut disparait et il ne reste alors plus qu'à rétablir les valeurs initiales ;)

 

En espérant que ce tuto vous sera Utile !

 

++

 

Baleyba (alias KaiserZEUS)

  • Merci 1
Lien vers le commentaire
Partager sur d’autres sites

Avec plaisir Johnny et French!

 

Merci à toi Johnny pour ton aide dans mon grand moment de solitude :icon_lol:

 

Tiens moi au jus ;)

Modifié par Baleyba
Lien vers le commentaire
Partager sur d’autres sites

Super Baleyba !! Je testerai ça dès que possible. Un grand merci en tout cas, on avait encore jamais trouvé de soluce pour cette erreur 03175 !

Lien vers le commentaire
Partager sur d’autres sites

Bonjour Iridium,

 

Merci pour ton commentaire. jap.gif?f-ed=1

N'hésite pas à nous faire un retour depuis ton 3GP (si je ne m'abuse).

 

++

Modifié par Baleyba
Lien vers le commentaire
Partager sur d’autres sites

Au final tu ne les modifies pas puisque quand le défaut disparait on les remet en valeurs d'origine.

C'est juste temporaire pour provoquer le recalcul des cheksums.

 

Pour infos ce sont les paramétrages des activations des menus disponibles dans le menu CAR du MMI.

Donc suite au passage de toutes les valeurs en +1 il ne faut pas s'étonner de voir temporairement le menu CAR rempli de toutes les options disponibles. Même celles dont ne dispose pas la voiture.

Une fois les valeurs d'origine rétablies, tout rentrera dans l'ordre.

Modifié par KaiserZEUS
Lien vers le commentaire
Partager sur d’autres sites

Salut KaiserZEUS !

 

Manipe testée ce matin et code défaut 03175 disparu (pour info, MMI 3G Advanced sur S4 B8).

Merci pour l'astuce ! :marcelpoire:

Lien vers le commentaire
Partager sur d’autres sites

Salut KaiserZEUS !

 

Manipe testée ce matin et code défaut 03175 disparu (pour info, MMI 3G Advanced sur S4 B8).

Merci pour l'astuce ! :marcelpoire:

 

EXTRA !! Je serai amené à effectuer la manip. d'ici peu, encore merci KaiserZEUS ;-)

Modifié par iridium
Lien vers le commentaire
Partager sur d’autres sites

Bonjour Kz

La manip que tu indiques fonctionne sur mon MMI 3G advanced

 

Ni le défaut 03276 ni le défaut 03175 ne réapparaissent => succès total

 

Juste un petite modif à faire sur ton tuto :

 

Tu dis

"- Commencer donc par activer le menu caché développeur si ce n'est pas déjà fait. Canal 10 du module 5F avec VCDS,"

 

Alors que c'est exactement :

Adaptation (10)

Canal 06

Passer la valeur de 0 à 1 ....

 

Voilà !!!

 

Encore bravo à toi

Lien vers le commentaire
Partager sur d’autres sites

Salut,

 

Merci pour vos retours ! Content que ça vous plaise ^^ :D

 

Merci Titou43, effectivement, je corrige de suite.

 

edit: Apparamment je ne peux plus éditer mon post trop vieux.

Modifié par KaiserZEUS
Lien vers le commentaire
Partager sur d’autres sites

Je viens d essayer sur un q5

 

Je n arrive pas le supprimer ...

 

Bizard

Lien vers le commentaire
Partager sur d’autres sites

Salut,

 

Es tu certain de ne pas avoir oublié de paramètre sur le page suivante et d'avoir bien redémarré l'appareil avant de rétablir les valeurs ?

 

Si c'est bien le cas, c'est que tu te trouves dans le cas particulier dont j'ai parlé en début de tuto qui nécessite soit de re-flasher le firmware et de re-tenter, soit d'utiliser ce que j'ai appelé la procédure adaptée avec un cable spécifique et flash partiel de la zone de langage.

 

cdlt,

Lien vers le commentaire
Partager sur d’autres sites

Je Viens de le faire sur mon rs et le code est bien supprimer

 

Par contre j ai un autre code défaut qui doit venir d'ailleurs.

 

Je le supprime mais revient a chaque fois .

 

ssks.jpg

Lien vers le commentaire
Partager sur d’autres sites

Il semble pouvoir y avoir plusieurs causes à ce défaut ?

- pb de communication

- changement de batterie et mauvais recodage

- changement du circuit de monitoring de la batterie

- ..

 

Tu as changé la batterie récemment ? ou recodé ?

Tu as fait des modifications ? upgrade mmi 3g+ par exemple ?

Modifié par KaiserZEUS
Lien vers le commentaire
Partager sur d’autres sites

La batterie est d origine mais commence a fatiguer a voir .

 

Sinon niveau modification juste

activation niveau batterie

Et modif dans le système audio pour le ripage audio et entrée aux

 

Aucun autre upgrade mis a part firmware et cartographie d'où le défaut du titre de ce topic

 

Rien de plus

 

Je vais tester un recodage de la batterie existante

Lien vers le commentaire
Partager sur d’autres sites

Bonjour French

j'ai lu un truc mais alors je ne sais plus il y a quelques mois concernant la modification afin d'afficher le niveau de batterie.....

 

Pour faire simple j'avais lu que cela pouvait créer un défaut sous certaines conditions (mais lesquelles je ne sais plus.....)

Ton défaut me parles et cela me fait penser à cela...

 

Il me semble mais alors vraiment de mémoire que si le niveau natterie s'affiche dans le MMI alors si tu débranches la batterie alors cela crée un défaut DTC

Cela doit être idem si elle est un peu faible et passe sous une certaine valeur de seuil ???

 

Pourquoi ne tenterais tu pas de supprimer le niveau batterie , donc revenir à l'initial et voir si le défaut persiste

Lien vers le commentaire
Partager sur d’autres sites

Test négatif .

 

Y à plus cas voir le soucis de la batterie

Lien vers le commentaire
Partager sur d’autres sites

  • 4 semaines plus tard...

Voila, meme erreur 03175 sur A6 C6 MMI3G PLUS, resolu il y a 5 minute avec ce tuto. Super!!!

 

Merci :marcelpoire:

Lien vers le commentaire
Partager sur d’autres sites

  • 2 semaines plus tard...

03157

 

Jmulard, as tu le vag com? Si oui tu a du biffer un option que tu n'as pas, ou tu a fait un mauvais codage en faisant croire a ta voiture quelle a une option qu en realité elle n'a pas. Du coup a chaque fois que tu fait un diagnostic la voiture cherche le modul de l'option que tu a choisi et ne le trouve pas, d'ou l'erreur.

 

Tu crois avoir modifier quelque chose?

Modifié par Megatron
Lien vers le commentaire
Partager sur d’autres sites

Je Viens de le faire sur mon rs et le code est bien supprimer

 

Par contre j ai un autre code défaut qui doit venir d'ailleurs.

 

Je le supprime mais revient a chaque fois .

 

ssks.jpg

 

 

Soucis résolu

 

J'avais un boîtier Tv Free de branché au cul et donnait le défaut .

 

Suppression de celui ci et plus de soucis .

 

Pour obtenir la Tv en roulant j ai fait la manip au vag com .

Lien vers le commentaire
Partager sur d’autres sites

Oui en effet, c'est compliqué!! je suis passé du mmi 2g au mmi 3G hdd, donc peut être quelque chose mal codé dans le mmi car le reste est ok.

Lien vers le commentaire
Partager sur d’autres sites

  • 2 semaines plus tard...

Bonjour,

 

j'ai effacé le 03176 mais j'ai un 03389 qui reste (data implausible).

 

Chose curieuse, j'ai mis à jour le FW du MMI en 767, et je n'ai pas de trace du défaut 03175.

 

Quelqu'un a déjà eu le 03389 ?

Lien vers le commentaire
Partager sur d’autres sites

Salut,

 

Le 03175 n'apparait pas systématiquement. Et principalement sur les mmi 3G. Tu as un 3G+ me semble t'il ?

 

Pour le 03389, il semble que ca vienne d'un mauvais codage avec le DSP Bose. Peux tu confirmer que tu es équipé de celà ?

exemple de topic qui en parle.

http://forums.audiworld.com/showthread.php?t=2856481&page=16

 

Si c'est bien le cas, j'ai un flash qui permet de le corriger la configuration mais pour Q7.

Pour Q5 faut que je me renseigne.

 

++

Kz

Lien vers le commentaire
Partager sur d’autres sites

Bonjour a tous

 

Non il me semble que comme moi Thierry n'a pas le BOSE

 

et pourtant j'ai l'erreur aussi ,depuis la dernière MAJ 767 ( MMI 3G+ )

 

 

03389 - Bloc de données non plausible

000 - -

Capture:

Etat du défaut: 01100000

Priorité du défaut: 2

Fréquence du défaut: 1

Compteur de RAZ: 152

Kilometrage: 59459 km

Heure: 0

Date: 2014.06.13

Temps: 20:18:03

 

Capture:

Tension: 14.30 V

Bits: 010

Modifié par JOHNNY5377
Lien vers le commentaire
Partager sur d’autres sites

Apparemment y'aurait un codage à faire avec le SVM suite à la mise à jour pour re paramétrer les options du véhicule: B&O, Bose, ...

 

Toujours d'après le lien ci-dessus:

I stopped by the dealership today and spoke with the tech who performed the 715_2 update to my car. I have a 2012 A6 C7 Prestige. He told me that the 715_2 update is the same across the board but they have to go online to tweek it according to the options you have..ie, the non Bose versus Bose versus the B.O whichever you may have. So let the dealership know that they have to calibrate it afterwards or it will be off.
Lien vers le commentaire
Partager sur d’autres sites

Salut,

 

Le 03175 n'apparait pas systématiquement. Et principalement sur les mmi 3G. Tu as un 3G+ me semble t'il ?

 

Pour le 03389, il semble que ca vienne d'un mauvais codage avec le DSP Bose. Peux tu confirmer que tu es équipé de celà ?

exemple de topic qui en parle.

http://forums.audiwo...2856481&page=16

 

Si c'est bien le cas, j'ai un flash qui permet de le corriger la configuration mais pour Q7.

Pour Q5 faut que je me renseigne.

 

++

Kz

Bonjour,

 

non Audi SQ5 avec MMI 3G+ et Audi Sound System 10 HP, pas de Bose.

 

Défaut 03176 effacé avec le calculateur online de Audizine, le 03389 reste mais bon tant pis je feindrai l'innonence vendredi lors de la révision, mais je pense que c'est un défaut générique.

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
 Partager

×
×
  • Créer...